Cross Site Scripting
Drupal core uses the third-party CKEditor library. This library has an error in parsing HTML that could lead to an XSS attack. CKEditor 4.16.1 and later include the fix.
Users of the CKEditor library via means other than Drupal core should update their 3rd party code (e.g. the WYSIWYG module for Drupal 7). The Drupal Security Team policy is not to alert for issues affecting 3rd party libraries unless those are shipped with Drupal core. See DRUPAL-SA-PSA-2016-004 for more details.
This issue is mitigated by the fact that it only affects sites with CKEditor enabled.
Install the latest version:
- If you are using Drupal 9.1, update to Drupal 9.1.9.
- If you are using Drupal 9.0, update to Drupal 9.0.14.
- If you are using Drupal 8.9, update to Drupal 8.9.16.
Versions of Drupal 8 prior to 8.9.x are end-of-life and do not receive security coverage.
- Greg Knaddison of the Drupal Security Team
- Jess of the Drupal Security Team
- Krzysztof Krzton
- Lee Rowlands of the Drupal Security Team
- Michael Hess of the Drupal Security Team